summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRĂ©mi Flamary <remi.flamary@gmail.com>2019-09-10 09:05:13 +0200
committerGitHub <noreply@github.com>2019-09-10 09:05:13 +0200
commit5e70a77fbb2feec513f21c9ef65dcc535329ace6 (patch)
tree3e800126f1de59640b0b1a09f763391ec3dc5318 /setup.py
parentf251b4d080a577c2cee890ca43d8ec3658332021 (diff)
parent29848c2ab362fc5ff466cb0e12409a1cca61644f (diff)
Merge pull request #91 from rflamary/v1.0
[MRG] Release 0.6
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py15
1 files changed, 12 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index bbcaf04..c08e3e0 100755
--- a/setup.py
+++ b/setup.py
@@ -53,17 +53,26 @@ setup(name='POT',
license = 'MIT',
scripts=[],
data_files=[],
- requires=["numpy","scipy","cython","matplotlib"],
- install_requires=["numpy","scipy","cython","matplotlib"],
+ requires=["numpy","scipy","cython"],
+ install_requires=["numpy","scipy","cython"],
classifiers=[
- 'Development Status :: 4 - Beta',
+ 'Development Status :: 5 - Production/Stable',
'Intended Audience :: Developers',
+ 'Intended Audience :: Education',
+ 'Intended Audience :: Science/Research',
+ 'License :: OSI Approved :: MIT License',
'Environment :: Console',
'Operating System :: OS Independent',
'Operating System :: MacOS',
'Operating System :: POSIX',
'Programming Language :: Python',
+ 'Programming Language :: C++',
+ 'Programming Language :: C',
+ 'Programming Language :: Cython',
'Topic :: Utilities',
+ 'Topic :: Scientific/Engineering :: Artificial Intelligence',
+ 'Topic :: Scientific/Engineering :: Mathematics',
+ 'Topic :: Scientific/Engineering :: Information Analysis',
'Programming Language :: Python :: 2',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',