summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorNicolas Courty <ncourty@irisa.fr>2020-02-28 11:46:51 +0100
committerGitHub <noreply@github.com>2020-02-28 11:46:51 +0100
commit00535f30ba5374f95df0a9f0781a12bea37abf63 (patch)
treeff4d363ce36677928d9d828c26148c3eac07a5da /setup.py
parente23f4d0646a3e8d28cc146c28574359585295249 (diff)
parent81e9d425b905b1b7fc0ee888556e60c692d9bb18 (diff)
Merge branch 'master' into osx-issue
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py15
1 files changed, 12 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 2cc3e50..bb00854 100755
--- a/setup.py
+++ b/setup.py
@@ -60,17 +60,26 @@ setup(name='POT',
license = 'MIT',
scripts=[],
data_files=[],
- requires=["numpy","scipy","cython","matplotlib"],
- install_requires=["numpy","scipy","cython","matplotlib"],
+ requires=["numpy","scipy","cython"],
+ install_requires=["numpy","scipy","cython"],
classifiers=[
- 'Development Status :: 4 - Beta',
+ 'Development Status :: 5 - Production/Stable',
'Intended Audience :: Developers',
+ 'Intended Audience :: Education',
+ 'Intended Audience :: Science/Research',
+ 'License :: OSI Approved :: MIT License',
'Environment :: Console',
'Operating System :: OS Independent',
'Operating System :: MacOS',
'Operating System :: POSIX',
'Programming Language :: Python',
+ 'Programming Language :: C++',
+ 'Programming Language :: C',
+ 'Programming Language :: Cython',
'Topic :: Utilities',
+ 'Topic :: Scientific/Engineering :: Artificial Intelligence',
+ 'Topic :: Scientific/Engineering :: Mathematics',
+ 'Topic :: Scientific/Engineering :: Information Analysis',
'Programming Language :: Python :: 2',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',