summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorNicolas Courty <ncourty@irisa.fr>2018-10-19 12:27:22 +0200
committerNicolas Courty <ncourty@irisa.fr>2018-10-19 12:27:22 +0200
commit47daf05106a99b8e1278e1b77328e9e4542c0c32 (patch)
tree077b0821415114c733bab814b2e55f16aaee6263 /setup.py
parentd4847a8c52c09319d751e2c7d29617398b08bae7 (diff)
add -tdlib=libc++ argument
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index c895034..7d42d8e 100755
--- a/setup.py
+++ b/setup.py
@@ -39,7 +39,9 @@ setup(name='POT',
sources=["ot/lp/emd_wrap.pyx", "ot/lp/EMD_wrapper.cpp"], # the Cython source and
# additional C++ source files
language="c++", # generate and compile C++ code,
- include_dirs=[numpy.get_include(),os.path.join(ROOT,'ot/lp')])),
+ include_dirs=[numpy.get_include(),os.path.join(ROOT,'ot/lp')],
+ extra_compile_args=["-stdlib=libc++"]
+ )),
platforms=['linux','macosx','windows'],
download_url='https://github.com/rflamary/POT/archive/{}.tar.gz'.format(__version__),
license = 'MIT',