summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRémi Flamary <remi.flamary@gmail.com>2021-12-26 23:39:04 +0100
committerGitHub <noreply@github.com>2021-12-26 23:39:04 +0100
commitac3559e75438dbf8ff4928bac51319d7de1d5e34 (patch)
tree1455c15d1898c2aea13112df8841ac1f05112a30 /setup.py
parent176c6b4a72e06233f6e238e4a80c94b853a0d493 (diff)
[MRG] Change numpy version (due to ABI change) (#326)
* update delease file and add it to doc ith mystè_parser * typos in release file * update PR template * test debug doc build * test debug doc build * wrog circleci * set proper version number * add numpy 1.20 constraint * remove python 3.6 deprecated in december * add python 3.10 * debug pip on windows * proper yml * remoe 3.10 becauqe of troch * next try * try distutils * back * try something * new stuf * debug yaml * test back to old vriso f numpy * try something * windows is worksing? * proper version numpy * update release file
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 44cc6dd..17bf968 100644
--- a/setup.py
+++ b/setup.py
@@ -68,8 +68,8 @@ setup(
license='MIT',
scripts=[],
data_files=[],
- setup_requires=["numpy>=1.16", "cython>=0.23"],
- install_requires=["numpy>=1.16", "scipy>=1.0"],
+ setup_requires=["numpy>=1.20", "cython>=0.23"],
+ install_requires=["numpy>=1.20", "scipy>=1.0"],
classifiers=[
'Development Status :: 5 - Production/Stable',
'Intended Audience :: Developers',