summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRémi Flamary <remi.flamary@gmail.com>2016-10-27 12:34:42 +0200
committerRémi Flamary <remi.flamary@gmail.com>2016-10-27 12:34:42 +0200
commite083f90ad09a3bd42beffea1e996f3b4a9b3ff76 (patch)
treef329e51af871ef1f415a87d4f9820c50c03fc4fc /setup.py
parent708aadb3396129c56cf128be04b7e87304b95070 (diff)
rename emd module to lp
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py6
1 files changed, 3 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 969ec99..60b9a9f 100755
--- a/setup.py
+++ b/setup.py
@@ -30,15 +30,15 @@ setup(name='POT',
packages=find_packages(),
ext_modules = cythonize(Extension(
"ot.emd.emd", # the extension name
- sources=["ot/emd/emd.pyx", "ot/emd/EMD_wrap.cpp"], # the Cython source and
+ sources=["ot/lp/emd.pyx", "ot/lp/EMD_wrap.cpp"], # the Cython source and
# additional C++ source files
language="c++", # generate and compile C++ code,
- include_dirs=[numpy.get_include(),os.path.join(ROOT,'ot/emd')])),
+ include_dirs=[numpy.get_include(),os.path.join(ROOT,'ot/lp')])),
platforms=['linux','macosx','windows'],
license = 'MIT',
scripts=[],
data_files=[],
- requires=["numpy (>=1.11)"],
+ requires=["numpy (>=1.11)","scipy (>=0.17)"],
classifiers=[
'Development Status :: 4 - Beta',
'Intended Audience :: Developers',