summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRémi Flamary <remi.flamary@gmail.com>2016-10-21 09:26:17 +0200
committerRémi Flamary <remi.flamary@gmail.com>2016-10-21 09:26:17 +0200
commit2109443f5bea396114d1f9e0563ba5c396378c57 (patch)
tree8717a7d7b04e3d862a5013cbdf2a9757e490dffa /setup.py
parent9816f9e29fd858602c2bd6d64deb8e157a9c3be2 (diff)
add emd
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py47
1 files changed, 47 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..3e31742
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,47 @@
+#!/usr/bin/env python
+
+from distutils.core import setup, Extension
+import numpy
+from Cython.Distutils import build_ext
+from Cython.Build import cythonize
+
+import os
+import glob
+
+version=0.1
+
+ROOT = os.path.abspath(os.path.dirname(__file__))
+README = open(os.path.join(ROOT, 'README.md')).read()
+
+setup(name='python-webgen',
+ version=version,
+ description='Python Optimal Transport Library',
+ long_description=README,
+ author=u'Remi Flamary',
+ author_email='remi.flamary@gmail.com',
+ url='https://github.com/rflamary/POT',
+ packages=['ot','ot.emd'],
+ ext_modules = cythonize(Extension(
+ "ot.emd.emd", # the extesion name
+ sources=["ot/emd/emd.pyx", "ot/emd/EMD_wrap.cpp"], # the Cython source and
+ # additional C++ source files
+ #extra_compile_args=['-fopenmp'],
+ #extra_link_args=['-fopenmp'],
+ language="c++", # generate and compile C++ code,
+ include_dirs=[numpy.get_include(),os.path.join(ROOT,'ot/emd')])),
+ platforms=['linux','macosx','windows'],
+ license = 'MIT',
+ scripts=[],
+ data_files=[],
+ requires=["numpy (>=1.11)"],
+ classifiers=[
+ 'Development Status :: 4 - Beta',
+ 'Intended Audience :: Developers',
+ 'Environment :: Console',
+ 'Operating System :: OS Independent',
+ 'Operating System :: MacOS',
+ 'Operating System :: POSIX',
+ 'Programming Language :: Python',
+ 'Topic :: Utilities'
+ ]
+ )