summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRémi Flamary <remi.flamary@gmail.com>2016-10-28 18:07:00 +0200
committerRémi Flamary <remi.flamary@gmail.com>2016-10-28 18:07:00 +0200
commitacfea8e233d683e7d505d64c0e5c4fb5d617918a (patch)
tree5188e6048ecef4d57d18812554ee8ef651609aa3 /setup.py
parente5a1abce0411cf2529645b5c0a279c29086e9010 (diff)
pipy v 0.1.4
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py6
1 files changed, 3 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index ade427f..c352d03 100755
--- a/setup.py
+++ b/setup.py
@@ -15,7 +15,7 @@ here = path.abspath(path.dirname(__file__))
import os
#import glob
-version='0.1.3'
+version='0.1.4'
ROOT = os.path.abspath(os.path.dirname(__file__))
README = open(os.path.join(ROOT, 'README.md')).read()
@@ -35,11 +35,11 @@ setup(name='POT',
language="c++", # generate and compile C++ code,
include_dirs=[numpy.get_include(),os.path.join(ROOT,'ot/lp')])),
platforms=['linux','macosx','windows'],
- download_url='https://github.com/rflamary/POT/archive/V0.1.tar.gz',
+ download_url='https://github.com/rflamary/POT/archive/V{}.tar.gz'.format(version),
license = 'MIT',
scripts=[],
data_files=[],
- requires=["numpy (>=1.11)","scipy (>=0.17)"],
+ requires=["numpy (>=1.11)","scipy (>=0.17)","cython (>=0.23)"],
classifiers=[
'Development Status :: 4 - Beta',
'Intended Audience :: Developers',