summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRémi Flamary <remi.flamary@gmail.com>2017-03-21 09:32:06 +0100
committerRémi Flamary <remi.flamary@gmail.com>2017-03-21 09:32:06 +0100
commit0bbd36c0b569e58c3d47177e816b3541fac4b916 (patch)
tree2cba51d5447afa3356470371adb216b587832678 /setup.py
parenta84f2c3e23edd1fa89975bd77b08672f518d5ca4 (diff)
cleanupt cpp wrapper name
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 144c325..51c6861 100755
--- a/setup.py
+++ b/setup.py
@@ -38,8 +38,8 @@ setup(name='POT',
url='https://github.com/rflamary/POT',
packages=find_packages(),
ext_modules = cythonize(Extension(
- "ot.lp.emd", # the extension name
- sources=["ot/lp/emd.pyx", "ot/lp/EMD_wrap.cpp"], # the Cython source and
+ "ot.lp.emd_wrap", # the extension name
+ sources=["ot/lp/emd_wrap.pyx", "ot/lp/EMD_wrap.cpp"], # the Cython source and
# additional C++ source files
language="c++", # generate and compile C++ code,
include_dirs=[numpy.get_include(),os.path.join(ROOT,'ot/lp')])),