summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRĂ©mi Flamary <remi.flamary@gmail.com>2022-02-23 09:53:13 +0100
committerGitHub <noreply@github.com>2022-02-23 09:53:13 +0100
commit3302cd48cdcc5d4832997bae921952cc3917fb59 (patch)
tree10181dc0e65e8eb72306cccc22d7a88a81250fcd /setup.py
parent50c0f17d00e3492c4d56a356af30cf00d6d07913 (diff)
[MRG] Build POT against oldest-supported-numpy (local PR) (#349)
* Configure setup to compile against oldest supported numpy version using the meta-package: https://pypi.org/project/oldest-supported-numpy/ - * Set minimum Python requirement to `>=3.7` in setup.py since !328 removed Python 3.6 support * Fix typo in pyproject.toml - * Update setup.py * Update setup.py and * build wheels * remove install dependencies for wheels building and build wheels * Apply suggestions from code review Co-authored-by: David M. Ghiurco <9147386+davidghiurco@users.noreply.github.com> * correct timing test add info in release file and build wheels * pep8 and Co-authored-by: David Ghiurco <9147386+davidghiurco@users.noreply.github.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 3 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index d46ae1c..c03191a 100644
--- a/setup.py
+++ b/setup.py
@@ -68,8 +68,9 @@ setup(
license='MIT',
scripts=[],
data_files=[],
- setup_requires=["numpy>=1.20", "cython>=0.23"],
- install_requires=["numpy>=1.20", "scipy>=1.0"],
+ setup_requires=["oldest-supported-numpy", "cython>=0.23"],
+ install_requires=["numpy>=1.16", "scipy>=1.0"],
+ python_requires=">=3.6",
classifiers=[
'Development Status :: 5 - Production/Stable',
'Intended Audience :: Developers',