summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRomain Tavenard <romain.tavenard@univ-rennes2.fr>2020-05-04 11:19:35 +0200
committerGitHub <noreply@github.com>2020-05-04 11:19:35 +0200
commite65c1f745cf2eacc6672727e7a3869efd8318768 (patch)
tree71590cd404f31806a5a99f0cf8faa8d9dca6b42e /setup.py
parent98d6cdcfa3a24ba07b9b4428250b7aee7e62f1ea (diff)
[WIP] Improved docs and changed scipy version (#163)
* Improved docs and changed scipy version * Fixed dependency bug in setup.py * dependencies set to minimal versions for tests * add requirements file * added minimal version build for scipy (testing 1.2) * bugfix in minimal deps build * (yet another) bugfix in minimal deps build * minimal deps now reflect README.md * minimal deps: no autograd nor pymanopt * refactored workflow names * minimal deps: no doctests * minimal deps: numpy 1.16 * trigger GH Actions on PR * better merge * re-add minimal-deps... * bugfix in yaml * enforce np>=1.16 * enforce scipy and cython versions too * requires / install_requires * requires / install_requires / requires * setup_requires Co-authored-by: RĂ©mi Flamary <remi.flamary@gmail.com>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 4640d00..91c24d9 100755
--- a/setup.py
+++ b/setup.py
@@ -67,7 +67,8 @@ setup(name='POT',
scripts=[],
data_files=[],
requires=["numpy", "scipy", "cython"],
- install_requires=["numpy", "scipy", "cython"],
+ setup_requires=["numpy>=1.16", "scipy>=1.0", "cython>=0.23"],
+ install_requires=["numpy>=1.16", "scipy>=1.0", "cython>=0.23"],
classifiers=[
'Development Status :: 5 - Production/Stable',
'Intended Audience :: Developers',