summaryrefslogtreecommitdiff
path: root/test
diff options
context:
space:
mode:
authorRĂ©mi Flamary <remi.flamary@gmail.com>2022-02-23 09:53:13 +0100
committerGitHub <noreply@github.com>2022-02-23 09:53:13 +0100
commit3302cd48cdcc5d4832997bae921952cc3917fb59 (patch)
tree10181dc0e65e8eb72306cccc22d7a88a81250fcd /test
parent50c0f17d00e3492c4d56a356af30cf00d6d07913 (diff)
[MRG] Build POT against oldest-supported-numpy (local PR) (#349)
* Configure setup to compile against oldest supported numpy version using the meta-package: https://pypi.org/project/oldest-supported-numpy/ - * Set minimum Python requirement to `>=3.7` in setup.py since !328 removed Python 3.6 support * Fix typo in pyproject.toml - * Update setup.py * Update setup.py and * build wheels * remove install dependencies for wheels building and build wheels * Apply suggestions from code review Co-authored-by: David M. Ghiurco <9147386+davidghiurco@users.noreply.github.com> * correct timing test add info in release file and build wheels * pep8 and Co-authored-by: David Ghiurco <9147386+davidghiurco@users.noreply.github.com>
Diffstat (limited to 'test')
-rw-r--r--test/test_utils.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/test/test_utils.py b/test/test_utils.py
index 5ad167b..3cfd295 100644
--- a/test/test_utils.py
+++ b/test/test_utils.py
@@ -67,7 +67,9 @@ def test_tic_toc():
t2 = ot.toq()
# test timing
- np.testing.assert_allclose(0.1, t, rtol=1e-1, atol=1e-1)
+ # np.testing.assert_allclose(0.1, t, rtol=1e-1, atol=1e-1)
+ # very slow macos github action equality not possible
+ assert t > 0.09
# test toc vs toq
np.testing.assert_allclose(t, t2, rtol=1e-1, atol=1e-1)