summaryrefslogtreecommitdiff
path: root/.travis.yml
diff options
context:
space:
mode:
Diffstat (limited to '.travis.yml')
-rw-r--r--.travis.yml5
1 files changed, 3 insertions, 2 deletions
diff --git a/.travis.yml b/.travis.yml
index 5e5694b..72fd29a 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -13,7 +13,7 @@ matrix:
python: 3.5
- os: linux
sudo: required
- python: 3.6
+ python: 3.6
- os: linux
sudo: required
python: 2.7
@@ -21,7 +21,6 @@ before_install:
- ./.travis/before_install.sh
before_script: # configure a headless display to test plot generation
- "export DISPLAY=:99.0"
- - "sh -e /etc/init.d/xvfb start"
- sleep 3 # give xvfb some time to start
# command to install dependencies
install:
@@ -30,6 +29,8 @@ install:
- pip install flake8 pytest "pytest-cov<2.6"
- pip install .
# command to run tests + check syntax style
+services:
+ - xvfb
script:
- python setup.py develop
- flake8 examples/ ot/ test/