summaryrefslogtreecommitdiff
path: root/.travis.yml
diff options
context:
space:
mode:
Diffstat (limited to '.travis.yml')
-rw-r--r--.travis.yml46
1 files changed, 46 insertions, 0 deletions
diff --git a/.travis.yml b/.travis.yml
new file mode 100644
index 0000000..5b3a26e
--- /dev/null
+++ b/.travis.yml
@@ -0,0 +1,46 @@
+dist: xenial # required for Python >= 3.7
+language: python
+matrix:
+ # allow_failures:
+ # - os: osx
+ # - os: windows
+ include:
+ - os: linux
+ sudo: required
+ python: 3.5
+ - os: linux
+ sudo: required
+ python: 3.6
+ - os: linux
+ sudo: required
+ python: 3.7
+ - os: linux
+ sudo: required
+ python: 2.7
+ # - os: osx
+ # sudo: required
+ # language: generic
+ # - name: "Python 3.7.3 on Windows"
+ # os: windows # Windows 10.0.17134 N/A Build 17134
+ # language: shell # 'language: python' is an error on Travis CI Windows
+ # before_install: choco install python
+ # env: PATH=/c/Python37:/c/Python37/Scripts:$PATH
+# before_script: # configure a headless display to test plot generation
+# - "export DISPLAY=:99.0"
+# - sleep 3 # give xvfb some time to start
+before_install:
+ - ./.travis/before_install.sh
+# command to install dependencies
+install:
+ - pip install -r requirements.txt
+ - pip install -U "numpy>=1.14" "scipy<1.3" # for numpy array formatting in doctests + scipy version: otherwise, pymanopt fails, cf <https://github.com/pymanopt/pymanopt/issues/77>
+ - pip install flake8 pytest "pytest-cov<2.6"
+ - pip install .
+# command to run tests + check syntax style
+services:
+ - xvfb
+script:
+ - python setup.py develop
+ - flake8 examples/ ot/ test/
+ - python -m pytest -v test/ ot/ --doctest-modules --ignore ot/gpu/ --cov=ot
+ # - py.test ot test