summaryrefslogtreecommitdiff
path: root/.travis.yml
diff options
context:
space:
mode:
Diffstat (limited to '.travis.yml')
-rw-r--r--.travis.yml8
1 files changed, 6 insertions, 2 deletions
diff --git a/.travis.yml b/.travis.yml
index 6126b3a..8023ec5 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -16,6 +16,10 @@ before_install:
# command to install dependencies
install:
- pip install -r requirements.txt
+ - pip install flake8 pytest
- python setup.py install
-# command to run tests
-script: python test/test_load_module.py -v
+# command to run tests + check syntax style
+script:
+ - python test/test_load_module.py -v
+ - flake8 .
+ - py.test ot test