summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.gitignore3
-rw-r--r--.travis.yml8
2 files changed, 9 insertions, 2 deletions
diff --git a/.gitignore b/.gitignore
index 21be4c9..6edce05 100644
--- a/.gitignore
+++ b/.gitignore
@@ -97,3 +97,6 @@ ENV/
# Rope project settings
.ropeproject
+
+# Mac stuff
+.DS_Store
diff --git a/.travis.yml b/.travis.yml
index 6126b3a..8023ec5 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -16,6 +16,10 @@ before_install:
# command to install dependencies
install:
- pip install -r requirements.txt
+ - pip install flake8 pytest
- python setup.py install
-# command to run tests
-script: python test/test_load_module.py -v
+# command to run tests + check syntax style
+script:
+ - python test/test_load_module.py -v
+ - flake8 .
+ - py.test ot test