summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--MANIFEST.in7
-rw-r--r--setup.cfg2
-rwxr-xr-xsetup.py3
3 files changed, 11 insertions, 1 deletions
diff --git a/MANIFEST.in b/MANIFEST.in
new file mode 100644
index 0000000..8c14549
--- /dev/null
+++ b/MANIFEST.in
@@ -0,0 +1,7 @@
+graft ot/lp/
+include README.md
+include ot/lp/core.h
+include ot/lp/EMD.h
+include ot/lp/emd.pyx
+include ot/lp/full_bipartitegraph.h
+include ot/lp/network_simplex_simple.h
diff --git a/setup.cfg b/setup.cfg
new file mode 100644
index 0000000..b88034e
--- /dev/null
+++ b/setup.cfg
@@ -0,0 +1,2 @@
+[metadata]
+description-file = README.md
diff --git a/setup.py b/setup.py
index c7870d3..ade427f 100755
--- a/setup.py
+++ b/setup.py
@@ -15,7 +15,7 @@ here = path.abspath(path.dirname(__file__))
import os
#import glob
-version='0.1'
+version='0.1.3'
ROOT = os.path.abspath(os.path.dirname(__file__))
README = open(os.path.join(ROOT, 'README.md')).read()
@@ -35,6 +35,7 @@ setup(name='POT',
language="c++", # generate and compile C++ code,
include_dirs=[numpy.get_include(),os.path.join(ROOT,'ot/lp')])),
platforms=['linux','macosx','windows'],
+ download_url='https://github.com/rflamary/POT/archive/V0.1.tar.gz',
license = 'MIT',
scripts=[],
data_files=[],