summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog13
-rw-r--r--debian/control27
-rw-r--r--debian/copyright84
-rwxr-xr-xdebian/rules15
-rw-r--r--debian/source/format1
-rw-r--r--debian/tests/control3
-rwxr-xr-xdebian/tests/upstream.sh16
-rw-r--r--debian/watch6
8 files changed, 165 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..5cba818
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,13 @@
+python-pot (0.6.0+dfsg-2) unstable; urgency=medium
+
+ * Watch file.
+ * DH compat 13.
+ * Fix tests that were trivially passing.
+
+ -- Gard Spreemann <gspr@nonempty.org> Wed, 08 Jul 2020 20:53:59 +0200
+
+python-pot (0.6.0+dfsg-1) unstable; urgency=medium
+
+ * Initial release. (Closes: #949381)
+
+ -- Gard Spreemann <gspr@nonempty.org> Sat, 25 Apr 2020 17:23:23 +0200
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..c834251
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,27 @@
+Source: python-pot
+Maintainer: Gard Spreemann <gspr@nonempty.org>
+Section: python
+Priority: optional
+Standards-Version: 4.5.0
+Build-Depends: cython3,
+ debhelper-compat (= 13),
+ dh-python,
+ python3-all-dev,
+ python3-numpy,
+ python3-scipy,
+ python3-setuptools
+Rules-Requires-Root: no
+Homepage: https://pythonot.github.io/
+Vcs-Browser: https://git.nonempty.org/debian-python-pot
+Vcs-Git: https://git.nonempty.org/debian-python-pot -b debian/sid
+
+Package: python3-pot
+Section: python
+Architecture: any
+Depends: ${misc:Depends},
+ ${python3:Depends},
+ ${shlibs:Depends}
+Description: Python optimal transport library
+ Python library with solvers for optimization problems related to
+ optimal transport in for example signal and image processing, and machine
+ learning.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..916802c
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,84 @@
+Format: https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Upstream-Name: POT
+Source: https://pythonot.github.io/
+License: MIT
+Files-Excluded: ot/externals/*
+Comment: Deleted upstream bundling of the funcsigs library for DFSG repack.
+ .
+ The non-Python files in ot/lp/ exist also in liblemon-dev, but the versions
+ included in POT are modified.
+
+Files: *
+Copyright: Rémi Flamary <remi.flamary@unice.fr>
+ Nicolas Courty <ncourty@irisa.fr>
+ Kilian Fatras <kilian.fatras@irisa.fr>
+ Titouan Vayer <titouan.vayer@irisa.fr>
+ Hicham Janati <hicham.janati@inria.fr>
+ Michael Perrot <michael.perrot@univ-st-etienne.fr>
+ Nathalie Gayraud <nat.gayraud@gmail.com>
+ Leo Gautheron <https://github.com/aje>
+ Erwan Vautier <erwan.vautier@gmail.com>
+ Hicham Janati <hicham.janati@inria.fr>
+License: MIT
+
+Files: ot/smooth.py
+Copyright: 2018, Mathieu Blondel
+License: BSD-2-clause
+
+Files: ot/lp/*
+Copyright: 2014 Antoine Rolet
+ Nicolas Bonneel
+License: BSD-2-clause
+
+Files: ot/lp/*.py*
+Copyright: Rémi Flamary <remi.flamary@unice.fr>
+License: MIT
+
+Files: debian/*
+Copyright: 2020 Gard Spreemann <gspr@nonempty.org>
+License: MIT
+
+License: MIT
+ Permission is hereby granted, free of charge, to any person obtaining a copy
+ of this software and associated documentation files (the "Software"), to deal
+ in the Software without restriction, including without limitation the rights
+ to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+ copies of the Software, and to permit persons to whom the Software is
+ furnished to do so, subject to the following conditions:
+ .
+ The above copyright notice and this permission notice shall be
+ included in all copies or substantial portions of the Software.
+ .
+ THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+ EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+ MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+ NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS
+ BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN
+ ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
+ CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+ SOFTWARE.
+
+License: BSD-2-clause
+ Redistribution and use in source and binary forms, with or without
+ modification, are permitted provided that the following conditions
+ are met:
+ .
+ 1. Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+ .
+ 2. Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
+ .
+ THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+ "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+ LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+ A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+ HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
+ INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
+ BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS
+ OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED
+ AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
+ LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY
+ WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+ POSSIBILITY OF SUCH DAMAGE. \ No newline at end of file
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..999317a
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,15 @@
+#!/usr/bin/make -f
+
+#export DH_VERBOSE = 1
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+export PYBUILD_NAME = pot
+
+%:
+ dh $@ --with python3 --buildsystem=pybuild
+
+execute_after_dh_auto_clean:
+ rm -f ot/lp/emd_wrap.cpp
+
+# Some of the build-time tests assume the existence of cupy, so we
+# currently disable all test.
+override_dh_auto_test:
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 0000000..163aaf8
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/debian/tests/control b/debian/tests/control
new file mode 100644
index 0000000..80e8c6e
--- /dev/null
+++ b/debian/tests/control
@@ -0,0 +1,3 @@
+Tests: upstream.sh
+Depends: python3-all, python3-pot, python3-pytest
+Restrictions: allow-stderr
diff --git a/debian/tests/upstream.sh b/debian/tests/upstream.sh
new file mode 100755
index 0000000..419d9a6
--- /dev/null
+++ b/debian/tests/upstream.sh
@@ -0,0 +1,16 @@
+#!/bin/bash
+
+set -e
+set -u
+
+testdir=test
+cp -R $testdir $AUTOPKGTEST_TMP
+cd $AUTOPKGTEST_TMP
+
+for py3ver in $(py3versions -vs)
+do
+ echo "Running tests with Python ${py3ver}."
+ /usr/bin/python${py3ver} -B -m pytest $testdir
+ rm -rf .pytest_cache
+ echo "**********"
+done
diff --git a/debian/watch b/debian/watch
new file mode 100644
index 0000000..d010629
--- /dev/null
+++ b/debian/watch
@@ -0,0 +1,6 @@
+version=4
+opts=filenamemangle=s/.+\/POT-?(\d\S+)\.tar\.gz/python-pot-$1\.tar\.gz/,\
+ dversionmangle=s/\+dfsg(\.\d+)?$//,\
+ uversionmangle=s/(\d)[_\.\-\+]?((RC|rc|pre|dev|beta|alpha)\d*)$/$1~$2/ \
+ https://github.com/PythonOT/POT/releases .*/archive/(\d\S+)\.tar\.gz
+ \ No newline at end of file