summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile5
-rw-r--r--README.md8
2 files changed, 8 insertions, 5 deletions
diff --git a/Makefile b/Makefile
index ead5e3a..9a54e42 100644
--- a/Makefile
+++ b/Makefile
@@ -30,11 +30,6 @@ sremove :
$(PYTHON) setup.py install --record files.txt
tr '\n' '\0' < files.txt | sudo xargs -0 rm -f --
rm files.txt
-
-doc :
- cd docs
- make html
- cd ..
clean :
$(PYTHON) setup.py clean
diff --git a/README.md b/README.md
index d7749db..d2d5049 100644
--- a/README.md
+++ b/README.md
@@ -1,2 +1,10 @@
# POT
Python Optimal Transport library
+
+This Python librarie is an open source implementation with several functions that allow to solve optimal transport problems in Python.
+
+It provides the following solvers:
+* Linear program (LP) OT solver/ Earth Movers Distance (using code from Antoine Rolet and Nicolas Bonnel)
+* Entropic regularization OT solver
+* Bregman projection for Wasserstein barycenter and unmixing
+* Optimal transport for domain adaptation