summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--RELEASES.md6
-rw-r--r--pyproject.toml2
-rw-r--r--requirements.txt2
-rw-r--r--setup.py4
4 files changed, 10 insertions, 4 deletions
diff --git a/RELEASES.md b/RELEASES.md
index ff65fc1..2a45465 100644
--- a/RELEASES.md
+++ b/RELEASES.md
@@ -11,6 +11,11 @@ tensorflow). We also introduce a simple benchmark on CPU GPU for the sinkhorn
solver that will be provided in the
[backend](https://pythonot.github.io/gen_modules/ot.backend.html) documentation.
+This release also brings a few changes in dependencies and compatibility. First
+we removed tests for Python 3.6 that will not be updated in the future.
+Also note that POT now depends on Numpy (>= 1.20) because a recent change in ABI is making the
+wheels non-compatible with older numpy versions. If you really need an older
+numpy POT will work with no problems but you will need to build it from source.
As always we want to that the contributors who helped make POT better (and bug free).
@@ -24,6 +29,7 @@ As always we want to that the contributors who helped make POT better (and bug f
#### Closed issues
+- Fix bug in older Numpy ABI (<1.20) (Issue #308, PR #326)
- Fix bug in `ot.dist` function when non euclidean distance (Issue #305, PR #306)
- Fix gradient scaling for functions using `nx.set_gradients` (Issue #309, PR
#310)
diff --git a/pyproject.toml b/pyproject.toml
index 3f8ae8b..93ebab3 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,3 +1,3 @@
[build-system]
-requires = ["setuptools", "wheel", "numpy>=1.16", "cython>=0.23"]
+requires = ["setuptools", "wheel", "numpy>=1.20", "cython>=0.23"]
build-backend = "setuptools.build_meta" \ No newline at end of file
diff --git a/requirements.txt b/requirements.txt
index 8b75241..f9934ce 100644
--- a/requirements.txt
+++ b/requirements.txt
@@ -1,4 +1,4 @@
-numpy>=1.16
+numpy>=1.20
scipy>=1.3
cython
matplotlib
diff --git a/setup.py b/setup.py
index 44cc6dd..17bf968 100644
--- a/setup.py
+++ b/setup.py
@@ -68,8 +68,8 @@ setup(
license='MIT',
scripts=[],
data_files=[],
- setup_requires=["numpy>=1.16", "cython>=0.23"],
- install_requires=["numpy>=1.16", "scipy>=1.0"],
+ setup_requires=["numpy>=1.20", "cython>=0.23"],
+ install_requires=["numpy>=1.20", "scipy>=1.0"],
classifiers=[
'Development Status :: 5 - Production/Stable',
'Intended Audience :: Developers',