summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile2
-rw-r--r--README.md22
-rw-r--r--docs/source/readme.rst22
-rw-r--r--notebooks/Demo_1D_OT.ipynb (renamed from examples/Demo_1D_OT.ipynb)0
-rw-r--r--notebooks/Demo_1D_barycenter.ipynb (renamed from examples/Demo_1D_barycenter.ipynb)0
-rw-r--r--notebooks/Demo_2D_OT_DomainAdaptation.ipynb (renamed from examples/Demo_2D_OT_DomainAdaptation.ipynb)0
-rw-r--r--notebooks/Demo_2D_OT_samples.ipynb (renamed from examples/Demo_2D_OT_samples.ipynb)0
-rw-r--r--notebooks/Demo_2D_OTmapping_DomainAdaptation.ipynb (renamed from examples/Demo_2D_OTmapping_DomainAdaptation.ipynb)0
-rw-r--r--notebooks/Demo_Compute_EMD.ipynb (renamed from examples/Demo_Compute_EMD.ipynb)0
-rw-r--r--notebooks/Demo_Ground_Loss.ipynb (renamed from examples/Demo_Ground_Loss.ipynb)0
-rw-r--r--notebooks/Demo_Image_ColorAdaptation.ipynb (renamed from examples/Demo_Image_ColorAdaptation.ipynb)0
-rw-r--r--notebooks/Demo_Image_ColorAdaptation_mapping.ipynb (renamed from examples/Demo_Image_ColorAdaptation_mapping.ipynb)0
-rw-r--r--notebooks/Demo_Optim_OTreg.ipynb (renamed from examples/Demo_Optim_OTreg.ipynb)0
-rw-r--r--notebooks/Demo_Wasserstein_Discriminant_Analysis.ipynb (renamed from examples/Demo_Wasserstein_Discriminant_Analysis.ipynb)0
-rwxr-xr-xsetup.py2
15 files changed, 24 insertions, 24 deletions
diff --git a/Makefile b/Makefile
index 34e9f20..22c1b50 100644
--- a/Makefile
+++ b/Makefile
@@ -46,4 +46,4 @@ rdoc:
notebook :
- ipython notebook --matplotlib=inline --notebook-dir=examples/
+ ipython notebook --matplotlib=inline --notebook-dir=notebooks/
diff --git a/README.md b/README.md
index 9664f3d..09da51b 100644
--- a/README.md
+++ b/README.md
@@ -76,17 +76,17 @@ The examples folder contain several examples and use case for the library. The f
Here is a list of the Python notebooks if you want a quick look:
-* [1D optimal transport](https://github.com/rflamary/POT/blob/master/examples/Demo_1D_OT.ipynb)
-* [OT Ground Loss](https://github.com/rflamary/POT/blob/master/examples/Demo_Ground_Loss.ipynb)
-* [Multiple EMD computation](https://github.com/rflamary/POT/blob/master/examples/Demo_Compute_EMD.ipynb)
-* [2D optimal transport on empirical distributions](https://github.com/rflamary/POT/blob/master/examples/Demo_2D_OT_samples.ipynb)
-* [1D Wasserstein barycenter](https://github.com/rflamary/POT/blob/master/examples/Demo_1D_barycenter.ipynb)
-* [OT with user provided regularization](https://github.com/rflamary/POT/blob/master/examples/Demo_Optim_OTreg.ipynb)
-* [Domain adaptation with optimal transport](https://github.com/rflamary/POT/blob/master/examples/Demo_2D_OT_DomainAdaptation.ipynb)
-* [Color transfer in images](https://github.com/rflamary/POT/blob/master/examples/Demo_Image_ColorAdaptation.ipynb)
-* [OT mapping estimation for domain adaptation](https://github.com/rflamary/POT/blob/master/examples/Demo_2D_OTmapping_DomainAdaptation.ipynb)
-* [OT mapping estimation for color transfer in images](https://github.com/rflamary/POT/blob/master/examples/Demo_Image_ColorAdaptation_mapping.ipynb)
-* [Wasserstein Discriminant Analysis](https://github.com/rflamary/POT/blob/master/examples/Demo_Wasserstein_Discriminant_Analysis.ipynb)
+* [1D optimal transport](https://github.com/rflamary/POT/blob/master/notebooks/Demo_1D_OT.ipynb)
+* [OT Ground Loss](https://github.com/rflamary/POT/blob/master/notebooks/Demo_Ground_Loss.ipynb)
+* [Multiple EMD computation](https://github.com/rflamary/POT/blob/master/notebooks/Demo_Compute_EMD.ipynb)
+* [2D optimal transport on empirical distributions](https://github.com/rflamary/POT/blob/master/notebooks/Demo_2D_OT_samples.ipynb)
+* [1D Wasserstein barycenter](https://github.com/rflamary/POT/blob/master/notebooks/Demo_1D_barycenter.ipynb)
+* [OT with user provided regularization](https://github.com/rflamary/POT/blob/master/notebooks/Demo_Optim_OTreg.ipynb)
+* [Domain adaptation with optimal transport](https://github.com/rflamary/POT/blob/master/notebooks/Demo_2D_OT_DomainAdaptation.ipynb)
+* [Color transfer in images](https://github.com/rflamary/POT/blob/master/notebooks/Demo_Image_ColorAdaptation.ipynb)
+* [OT mapping estimation for domain adaptation](https://github.com/rflamary/POT/blob/master/notebooks/Demo_2D_OTmapping_DomainAdaptation.ipynb)
+* [OT mapping estimation for color transfer in images](https://github.com/rflamary/POT/blob/master/notebooks/Demo_Image_ColorAdaptation_mapping.ipynb)
+* [Wasserstein Discriminant Analysis](https://github.com/rflamary/POT/blob/master/notebooks/Demo_Wasserstein_Discriminant_Analysis.ipynb)
You can also see the notebooks with [Jupyter nbviewer](https://nbviewer.jupyter.org/github/rflamary/POT/tree/master/examples/).
diff --git a/docs/source/readme.rst b/docs/source/readme.rst
index 9d8c49f..6898296 100644
--- a/docs/source/readme.rst
+++ b/docs/source/readme.rst
@@ -100,27 +100,27 @@ library. The full documentation is available on
Here is a list of the Python notebooks if you want a quick look:
- `1D optimal
- transport <https://github.com/rflamary/POT/blob/master/examples/Demo_1D_OT.ipynb>`__
+ transport <https://github.com/rflamary/POT/blob/master/notebooks/Demo_1D_OT.ipynb>`__
- `OT Ground
- Loss <https://github.com/rflamary/POT/blob/master/examples/Demo_Ground_Loss.ipynb>`__
+ Loss <https://github.com/rflamary/POT/blob/master/notebooks/Demo_Ground_Loss.ipynb>`__
- `Multiple EMD
- computation <https://github.com/rflamary/POT/blob/master/examples/Demo_Compute_EMD.ipynb>`__
+ computation <https://github.com/rflamary/POT/blob/master/notebooks/Demo_Compute_EMD.ipynb>`__
- `2D optimal transport on empirical
- distributions <https://github.com/rflamary/POT/blob/master/examples/Demo_2D_OT_samples.ipynb>`__
+ distributions <https://github.com/rflamary/POT/blob/master/notebooks/Demo_2D_OT_samples.ipynb>`__
- `1D Wasserstein
- barycenter <https://github.com/rflamary/POT/blob/master/examples/Demo_1D_barycenter.ipynb>`__
+ barycenter <https://github.com/rflamary/POT/blob/master/notebooks/Demo_1D_barycenter.ipynb>`__
- `OT with user provided
- regularization <https://github.com/rflamary/POT/blob/master/examples/Demo_Optim_OTreg.ipynb>`__
+ regularization <https://github.com/rflamary/POT/blob/master/notebooks/Demo_Optim_OTreg.ipynb>`__
- `Domain adaptation with optimal
- transport <https://github.com/rflamary/POT/blob/master/examples/Demo_2D_OT_DomainAdaptation.ipynb>`__
+ transport <https://github.com/rflamary/POT/blob/master/notebooks/Demo_2D_OT_DomainAdaptation.ipynb>`__
- `Color transfer in
- images <https://github.com/rflamary/POT/blob/master/examples/Demo_Image_ColorAdaptation.ipynb>`__
+ images <https://github.com/rflamary/POT/blob/master/notebooks/Demo_Image_ColorAdaptation.ipynb>`__
- `OT mapping estimation for domain
- adaptation <https://github.com/rflamary/POT/blob/master/examples/Demo_2D_OTmapping_DomainAdaptation.ipynb>`__
+ adaptation <https://github.com/rflamary/POT/blob/master/notebooks/Demo_2D_OTmapping_DomainAdaptation.ipynb>`__
- `OT mapping estimation for color transfer in
- images <https://github.com/rflamary/POT/blob/master/examples/Demo_Image_ColorAdaptation_mapping.ipynb>`__
+ images <https://github.com/rflamary/POT/blob/master/notebooks/Demo_Image_ColorAdaptation_mapping.ipynb>`__
- `Wasserstein Discriminant
- Analysis <https://github.com/rflamary/POT/blob/master/examples/Demo_Wasserstein_Discriminant_Analysis.ipynb>`__
+ Analysis <https://github.com/rflamary/POT/blob/master/notebooks/Demo_Wasserstein_Discriminant_Analysis.ipynb>`__
You can also see the notebooks with `Jupyter
nbviewer <https://nbviewer.jupyter.org/github/rflamary/POT/tree/master/examples/>`__.
diff --git a/examples/Demo_1D_OT.ipynb b/notebooks/Demo_1D_OT.ipynb
index 087b3bc..087b3bc 100644
--- a/examples/Demo_1D_OT.ipynb
+++ b/notebooks/Demo_1D_OT.ipynb
diff --git a/examples/Demo_1D_barycenter.ipynb b/notebooks/Demo_1D_barycenter.ipynb
index c93d00b..c93d00b 100644
--- a/examples/Demo_1D_barycenter.ipynb
+++ b/notebooks/Demo_1D_barycenter.ipynb
diff --git a/examples/Demo_2D_OT_DomainAdaptation.ipynb b/notebooks/Demo_2D_OT_DomainAdaptation.ipynb
index b713d5b..b713d5b 100644
--- a/examples/Demo_2D_OT_DomainAdaptation.ipynb
+++ b/notebooks/Demo_2D_OT_DomainAdaptation.ipynb
diff --git a/examples/Demo_2D_OT_samples.ipynb b/notebooks/Demo_2D_OT_samples.ipynb
index e20b09b..e20b09b 100644
--- a/examples/Demo_2D_OT_samples.ipynb
+++ b/notebooks/Demo_2D_OT_samples.ipynb
diff --git a/examples/Demo_2D_OTmapping_DomainAdaptation.ipynb b/notebooks/Demo_2D_OTmapping_DomainAdaptation.ipynb
index 4b75f58..4b75f58 100644
--- a/examples/Demo_2D_OTmapping_DomainAdaptation.ipynb
+++ b/notebooks/Demo_2D_OTmapping_DomainAdaptation.ipynb
diff --git a/examples/Demo_Compute_EMD.ipynb b/notebooks/Demo_Compute_EMD.ipynb
index cda9a59..cda9a59 100644
--- a/examples/Demo_Compute_EMD.ipynb
+++ b/notebooks/Demo_Compute_EMD.ipynb
diff --git a/examples/Demo_Ground_Loss.ipynb b/notebooks/Demo_Ground_Loss.ipynb
index a39a07f..a39a07f 100644
--- a/examples/Demo_Ground_Loss.ipynb
+++ b/notebooks/Demo_Ground_Loss.ipynb
diff --git a/examples/Demo_Image_ColorAdaptation.ipynb b/notebooks/Demo_Image_ColorAdaptation.ipynb
index 16e5208..16e5208 100644
--- a/examples/Demo_Image_ColorAdaptation.ipynb
+++ b/notebooks/Demo_Image_ColorAdaptation.ipynb
diff --git a/examples/Demo_Image_ColorAdaptation_mapping.ipynb b/notebooks/Demo_Image_ColorAdaptation_mapping.ipynb
index 51b91ed..51b91ed 100644
--- a/examples/Demo_Image_ColorAdaptation_mapping.ipynb
+++ b/notebooks/Demo_Image_ColorAdaptation_mapping.ipynb
diff --git a/examples/Demo_Optim_OTreg.ipynb b/notebooks/Demo_Optim_OTreg.ipynb
index 5731687..5731687 100644
--- a/examples/Demo_Optim_OTreg.ipynb
+++ b/notebooks/Demo_Optim_OTreg.ipynb
diff --git a/examples/Demo_Wasserstein_Discriminant_Analysis.ipynb b/notebooks/Demo_Wasserstein_Discriminant_Analysis.ipynb
index 2d3424e..2d3424e 100644
--- a/examples/Demo_Wasserstein_Discriminant_Analysis.ipynb
+++ b/notebooks/Demo_Wasserstein_Discriminant_Analysis.ipynb
diff --git a/setup.py b/setup.py
index 63d071c..347c882 100755
--- a/setup.py
+++ b/setup.py
@@ -44,7 +44,7 @@ setup(name='POT',
language="c++", # generate and compile C++ code,
include_dirs=[numpy.get_include(),os.path.join(ROOT,'ot/lp')])),
platforms=['linux','macosx','windows'],
- download_url='https://github.com/rflamary/POT/archive/V{}.tar.gz'.format(__version__),
+ download_url='https://github.com/rflamary/POT/archive/{}.tar.gz'.format(__version__),
license = 'MIT',
scripts=[],
data_files=[],