summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--README.md8
-rwxr-xr-xsetup.py3
2 files changed, 9 insertions, 2 deletions
diff --git a/README.md b/README.md
index 55e9e8a..cd69e68 100644
--- a/README.md
+++ b/README.md
@@ -17,6 +17,12 @@ The Library has been tested on Linux and MacOSX. It requires a C++ compiler for
- Numpy (>=1.11)
- Scipy (>=0.17)
+- Cython (>=0.23)
+- Matplotlib (>=1.5)
+Under debian based linux the dependencies can be installed with
+```
+sudo apt-get install python-numpy python-scipy python-matplotlib cython
+```
To install the library, you can install it locally (after downloading it) on you machine using
```
@@ -37,7 +43,7 @@ Note that for easier access the module is name ot instead of pot.
## Examples
-The examples folder contain several examples and use case for the library.
+The examples folder contain several examples and use case for the library. The full documentation is available on [Readthedoc](http://pot.readthedocs.io/)
Here is a list of the Python notebook if you want a quick look:
diff --git a/setup.py b/setup.py
index c352d03..3397cda 100755
--- a/setup.py
+++ b/setup.py
@@ -39,7 +39,8 @@ setup(name='POT',
license = 'MIT',
scripts=[],
data_files=[],
- requires=["numpy (>=1.11)","scipy (>=0.17)","cython (>=0.23)"],
+ requires=["numpy (>=1.11)","scipy (>=0.17)","cython (>=0.23)","matplotlib (>=1.5)"],
+ install_requires=["numpy (>=1.11)","scipy (>=0.17)","cython (>=0.23)","matplotlib (>=1.5)"],
classifiers=[
'Development Status :: 4 - Beta',
'Intended Audience :: Developers',