summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile19
1 files changed, 14 insertions, 5 deletions
diff --git a/Makefile b/Makefile
index 22c1b50..98f5614 100644
--- a/Makefile
+++ b/Makefile
@@ -31,19 +31,28 @@ sremove :
tr '\n' '\0' < files.txt | sudo xargs -0 rm -f --
rm files.txt
-clean :
+clean : FORCE
$(PYTHON) setup.py clean
+
+pep8 :
+ flake8 examples/ ot/ test/
+
+test : FORCE pep8
+ python -m py.test -v test/ --cov=ot --cov-report html:cov_html
-test:
- pytest
+pytest : FORCE
+ python -m py.test -v test/ --cov=ot
-uploadpypi:
+uploadpypi :
#python setup.py register
python setup.py sdist upload -r pypi
-rdoc:
+rdoc :
pandoc --from=markdown --to=rst --output=docs/source/readme.rst README.md
notebook :
ipython notebook --matplotlib=inline --notebook-dir=notebooks/
+
+
+FORCE :