summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 0b17082..a4fae8e 100644
--- a/Makefile
+++ b/Makefile
@@ -11,7 +11,7 @@ help :
@echo " remove - remove the package (local user)"
@echo " sremove - remove the package (system with sudo)"
@echo " clean - remove any temporary files"
- @echo " notebook - launch ipython notebook"
+ @echo " notebook - launch ipython notebook"
build :
$(PYTHON) setup.py build
@@ -33,11 +33,14 @@ sremove :
clean :
$(PYTHON) setup.py clean
-
+
uploadpypi:
python setup.py register
python setup.py sdist upload -r pypi
+rdoc:
+ pandoc pandoc --from=markdown --to=rst --output=docs/source/readme.rst README.md
+
notebook :
ipython notebook --matplotlib=inline --notebook-dir=examples/