summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 1abc6e9..84a644b 100644
--- a/Makefile
+++ b/Makefile
@@ -1,6 +1,7 @@
PYTHON=python3
+branch := $(shell git symbolic-ref --short -q HEAD)
help :
@echo "The following make targets are available:"
@@ -57,6 +58,16 @@ rdoc :
notebook :
ipython notebook --matplotlib=inline --notebook-dir=notebooks/
+bench :
+ @git stash >/dev/null 2>&1
+ @echo 'Branch master'
+ @git checkout master >/dev/null 2>&1
+ python3 $(script)
+ @echo 'Branch $(branch)'
+ @git checkout $(branch) >/dev/null 2>&1
+ python3 $(script)
+ @git stash apply >/dev/null 2>&1
+
autopep8 :
autopep8 -ir test ot examples --jobs -1