summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile19
1 files changed, 15 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 89c30c3..cafda8e 100644
--- a/Makefile
+++ b/Makefile
@@ -3,6 +3,8 @@
PYTHON=python3
branch := $(shell git symbolic-ref --short -q HEAD)
+
+
help :
@echo "The following make targets are available:"
@echo " help - print this message"
@@ -13,6 +15,7 @@ help :
@echo " sremove - remove the package (system with sudo)"
@echo " clean - remove any temporary files"
@echo " notebook - launch ipython notebook"
+
build :
$(PYTHON) setup.py build
@@ -47,14 +50,15 @@ test : FORCE pep8
pytest : FORCE
$(PYTHON) -m pytest -v test/ --doctest-modules --ignore ot/gpu/ --cov=ot
-uploadpypi :
- #python setup.py register
- $(PYTHON) setup.py sdist upload -r pypi
+release :
+ twine upload dist/*
+
+release_test :
+ twine upload --repository-url https://test.pypi.org/legacy/ dist/*
rdoc :
pandoc --from=markdown --to=rst --output=docs/source/readme.rst README.md
-
notebook :
ipython notebook --matplotlib=inline --notebook-dir=notebooks/
@@ -73,6 +77,13 @@ autopep8 :
aautopep8 :
autopep8 -air test ot examples --jobs -1
+
+wheels :
+ CIBW_BEFORE_BUILD="pip install numpy cython" cibuildwheel --platform linux --output-dir dist
+
+dist : wheels
+ $(PYTHON) setup.py sdist
+
pydocstyle :
pydocstyle ot