summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules15
1 files changed, 15 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..999317a
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,15 @@
+#!/usr/bin/make -f
+
+#export DH_VERBOSE = 1
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+export PYBUILD_NAME = pot
+
+%:
+ dh $@ --with python3 --buildsystem=pybuild
+
+execute_after_dh_auto_clean:
+ rm -f ot/lp/emd_wrap.cpp
+
+# Some of the build-time tests assume the existence of cupy, so we
+# currently disable all test.
+override_dh_auto_test: