summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Mulansky <mario.mulansky@gmx.net>2014-10-16 11:16:59 +0200
committerMario Mulansky <mario.mulansky@gmx.net>2014-10-16 11:16:59 +0200
commit944e666163cc8db9860cfb76270e97d9437fcaed (patch)
tree234a01ecdf95069e787af6c60af03b03604663cb
parent39433f4cf4994edacf1814aff5d5f54b666d8f47 (diff)
added travis build script
-rw-r--r--.travis.yml13
1 files changed, 13 insertions, 0 deletions
diff --git a/.travis.yml b/.travis.yml
new file mode 100644
index 0000000..cec04c2
--- /dev/null
+++ b/.travis.yml
@@ -0,0 +1,13 @@
+language: python
+python:
+ - "2.6"
+ - "2.7"
+
+before_install:
+ - sudo apt-get install -qq cython
+
+script:
+ - python setup.py build_ext --inplace
+ - cd test
+ - nosetests
+