summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Mulansky <mario.mulansky@gmx.net>2014-10-10 17:32:54 +0200
committerMario Mulansky <mario.mulansky@gmx.net>2014-10-10 17:32:54 +0200
commitc70a030f23b89d086772177300040081c8ac1c54 (patch)
tree16e0718a31c1f36c32eb9ad714d83a2d68913422
parentdea3679bf53326301d626f1e8e24d2f635685307 (diff)
added note on running tests
-rw-r--r--Readme.md6
1 files changed, 6 insertions, 0 deletions
diff --git a/Readme.md b/Readme.md
index aa1078e..cdb2597 100644
--- a/Readme.md
+++ b/Readme.md
@@ -14,6 +14,7 @@ To use PySpike you need Python installed with the following additional packages:
- scipy
- matplotlib
- cython
+- nosetests (for running the tests)
In particular, make sure that [cython](http://www.cython.org) is configured properly and able to locate a C compiler.
@@ -23,6 +24,11 @@ To install PySpike, simply download the source, i.e. via git, and run the setup.
cd PySpike
python setup.py build_ext --inplace
+The you can run the tests using the `nosetests` test framework:
+
+ cd test
+ nosetests
+
## Loading spike trains