summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Mulansky <mario.mulansky@gmx.net>2014-10-10 15:18:48 +0200
committerMario Mulansky <mario.mulansky@gmx.net>2014-10-10 15:18:48 +0200
commit62f792fa52801234d4f9c33800a44b0308e9b8ab (patch)
tree96285b6eb0c5444829cc1cbc4976b31df1d64cbb
parentcefbc57be0a8badc21453ea460608b3caf344673 (diff)
Basic readme docs
-rw-r--r--Readme6
-rw-r--r--Readme.md37
2 files changed, 37 insertions, 6 deletions
diff --git a/Readme b/Readme
deleted file mode 100644
index c82233b..0000000
--- a/Readme
+++ /dev/null
@@ -1,6 +0,0 @@
-PySpike
-=======
-
-PySpike is a Python library for numerical analysis of spike train similarity. Its core functionality are the implementation of the bivariate [ISI and SPIKE distance](http://www.scholarpedia.org/article/Measures_of_spike_train_synchrony). Additionally, it allows to compute multi-variate spike train distances, averaging and general spike train processing.
-
-All source codes are published under the liberal [MIT License](http://opensource.org/licenses/MIT).
diff --git a/Readme.md b/Readme.md
new file mode 100644
index 0000000..368eef4
--- /dev/null
+++ b/Readme.md
@@ -0,0 +1,37 @@
+# PySpike
+
+PySpike is a Python library for numerical analysis of spike train similarity.
+Its core functionality are the implementation of the bivariate [ISI and SPIKE distance](http://www.scholarpedia.org/article/Measures_of_spike_train_synchrony).
+Additionally, it allows to compute multi-variate spike train distances, averaging and general spike train processing.
+
+All source codes are published under the liberal [MIT License](http://opensource.org/licenses/MIT).
+
+## Requirements and Installation
+
+To use PySpike you need Python installed with the following additional packages:
+
+- numpy
+- scipy
+- matplotlib
+- cython
+
+In particular, make sure that [cython](http://www.cython.org) is configured properly and able to locate a C compiler.
+
+To install PySpike, simply download the source, i.e. via git, and run the setup.py script:
+ git clone ...
+ cd PySpike
+ python setup.py build_ext --inplace
+
+## Loading spike trains
+
+
+## Computing bi-variate distances
+
+
+## Computing multi-variate distances
+
+
+## Plotting
+
+
+## Averaging \ No newline at end of file