summaryrefslogtreecommitdiff
path: root/pyspike/PieceWiseConstFunc.py
diff options
context:
space:
mode:
authorMario Mulansky <mario.mulansky@gmx.net>2015-07-07 18:55:32 +0200
committerMario Mulansky <mario.mulansky@gmx.net>2015-07-07 18:55:32 +0200
commit5119d47d0f00c3f7203cf94460730b59a7e473ec (patch)
treef17eecd4d2cb7da865b6fe4a1b4faf268ab77334 /pyspike/PieceWiseConstFunc.py
parent0ece782e1579660cdb71e077cbaaf9f76e97bef4 (diff)
add disable_backend_warning property
Users can now disable the warning messages produced when the cython backend is not available by writing spk.disable_backend_warning = True in the beginning
Diffstat (limited to 'pyspike/PieceWiseConstFunc.py')
-rw-r--r--pyspike/PieceWiseConstFunc.py7
1 files changed, 5 insertions, 2 deletions
diff --git a/pyspike/PieceWiseConstFunc.py b/pyspike/PieceWiseConstFunc.py
index 2705443..23ff536 100644
--- a/pyspike/PieceWiseConstFunc.py
+++ b/pyspike/PieceWiseConstFunc.py
@@ -6,6 +6,7 @@ from __future__ import print_function
import numpy as np
import collections
+import pyspike
##############################################################
@@ -191,8 +192,10 @@ class PieceWiseConstFunc(object):
from cython.cython_add import add_piece_wise_const_cython as \
add_piece_wise_const_impl
except ImportError:
- print("Warning: add_piece_wise_const_cython not found. Make sure \
-that PySpike is installed by running\n 'python setup.py build_ext --inplace'! \
+ if not(pyspike.disable_backend_warning):
+ print("Warning: add_piece_wise_const_cython not found. Make \
+sure that PySpike is installed by running\n \
+'python setup.py build_ext --inplace'! \
\n Falling back to slow python backend.")
# use python backend
from cython.python_backend import add_piece_wise_const_python as \