summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMario Mulansky <mario.mulansky@gmx.net>2015-08-26 12:10:01 +0200
committerMario Mulansky <mario.mulansky@gmx.net>2018-06-02 12:58:46 -0700
commit0c710a2450a055091fe6de2313d6240671d1c74d (patch)
tree71f6d604779c636c2aa448887de500af07a89673 /setup.py
parent44d23620d2faa78ca74437fbd3f1b95da722a853 (diff)
reorganized directionality module
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py19
1 files changed, 15 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 5b9e677..9ba1da6 100644
--- a/setup.py
+++ b/setup.py
@@ -30,7 +30,8 @@ class numpy_include(object):
if os.path.isfile("pyspike/cython/cython_add.c") and \
os.path.isfile("pyspike/cython/cython_profiles.c") and \
- os.path.isfile("pyspike/cython/cython_distances.c"):
+ os.path.isfile("pyspike/cython/cython_distances.c") and \
+ os.path.isfile("pyspike/cython/cython_directionality.c"):
use_c = True
else:
use_c = False
@@ -45,7 +46,9 @@ if use_cython: # Cython is available, compile .pyx -> .c
Extension("pyspike.cython.cython_profiles",
["pyspike/cython/cython_profiles.pyx"]),
Extension("pyspike.cython.cython_distances",
- ["pyspike/cython/cython_distances.pyx"])
+ ["pyspike/cython/cython_distances.pyx"]),
+ Extension("pyspike.cython.cython_directionality",
+ ["pyspike/cython/cython_directionality.pyx"])
]
cmdclass.update({'build_ext': build_ext})
elif use_c: # c files are there, compile to binaries
@@ -55,7 +58,9 @@ elif use_c: # c files are there, compile to binaries
Extension("pyspike.cython.cython_profiles",
["pyspike/cython/cython_profiles.c"]),
Extension("pyspike.cython.cython_distances",
- ["pyspike/cython/cython_distances.c"])
+ ["pyspike/cython/cython_distances.c"]),
+ Extension("pyspike.cython.cython_directionality",
+ ["pyspike/cython/cython_directionality.c"])
]
# neither cython nor c files available -> automatic fall-back to python backend
@@ -96,5 +101,11 @@ train similarity',
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6'
- ]
+ ],
+ package_data={
+ 'pyspike': ['cython/cython_add.c', 'cython/cython_profiles.c',
+ 'cython/cython_distances.c',
+ 'cython/cython_directionality.c'],
+ 'test': ['Spike_testdata.txt']
+ }
)