summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMario Mulansky <mario.mulansky@gmx.net>2015-10-10 20:45:09 +0200
committerMario Mulansky <mario.mulansky@gmx.net>2018-06-02 12:59:43 -0700
commit18ea80e2d01e9eb4ceee17219f91098efbcdf67c (patch)
treed7819736b059e9885d53c14e28160d6487d93e6c /setup.py
parenta5e6a12a619cb9528a4cf7f3ef8f082e5eb877c2 (diff)
spike sync filtering, cython sim ann
Added function for filtering out events based on a threshold for the spike sync values. Usefull for focusing on synchronous events during directionality analysis. Also added cython version of simulated annealing for performance.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py14
1 files changed, 10 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 9ba1da6..808a122 100644
--- a/setup.py
+++ b/setup.py
@@ -31,7 +31,8 @@ class numpy_include(object):
if os.path.isfile("pyspike/cython/cython_add.c") and \
os.path.isfile("pyspike/cython/cython_profiles.c") and \
os.path.isfile("pyspike/cython/cython_distances.c") and \
- os.path.isfile("pyspike/cython/cython_directionality.c"):
+ os.path.isfile("pyspike/cython/cython_directionality.c") and \
+ os.path.isfile("pyspike/cython/cython_simulated_annealing.c"):
use_c = True
else:
use_c = False
@@ -48,7 +49,9 @@ if use_cython: # Cython is available, compile .pyx -> .c
Extension("pyspike.cython.cython_distances",
["pyspike/cython/cython_distances.pyx"]),
Extension("pyspike.cython.cython_directionality",
- ["pyspike/cython/cython_directionality.pyx"])
+ ["pyspike/cython/cython_directionality.pyx"]),
+ Extension("pyspike.cython.cython_simulated_annealing",
+ ["pyspike/cython/cython_simulated_annealing.pyx"])
]
cmdclass.update({'build_ext': build_ext})
elif use_c: # c files are there, compile to binaries
@@ -60,7 +63,9 @@ elif use_c: # c files are there, compile to binaries
Extension("pyspike.cython.cython_distances",
["pyspike/cython/cython_distances.c"]),
Extension("pyspike.cython.cython_directionality",
- ["pyspike/cython/cython_directionality.c"])
+ ["pyspike/cython/cython_directionality.c"]),
+ Extension("pyspike.cython.cython_simulated_annealing",
+ ["pyspike/cython/cython_simulated_annealing.c"])
]
# neither cython nor c files available -> automatic fall-back to python backend
@@ -105,7 +110,8 @@ train similarity',
package_data={
'pyspike': ['cython/cython_add.c', 'cython/cython_profiles.c',
'cython/cython_distances.c',
- 'cython/cython_directionality.c'],
+ 'cython/cython_directionality.c',
+ 'cython/cython_simulated_annealing.c'],
'test': ['Spike_testdata.txt']
}
)