summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMario Mulansky <mario.mulansky@gmx.net>2015-12-14 16:50:55 +0100
committerMario Mulansky <mario.mulansky@gmx.net>2015-12-14 16:50:55 +0100
commit9061f2a0c13134e53f937d730295a421fd671ea3 (patch)
tree799a2fa0e0f7558ece400de15ca8d1358565c066 /setup.py
parent64b680238ac5bcafbf3ce67ed2a4d7487098b43d (diff)
removed directionality from __init__ and setup.py
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py11
1 files changed, 3 insertions, 8 deletions
diff --git a/setup.py b/setup.py
index a1ab122..8ef431a 100644
--- a/setup.py
+++ b/setup.py
@@ -23,8 +23,7 @@ else:
if os.path.isfile("pyspike/cython/cython_add.c") and \
os.path.isfile("pyspike/cython/cython_profiles.c") and \
- os.path.isfile("pyspike/cython/cython_distances.c") and \
- os.path.isfile("pyspike/directionality/cython/cython_directionality.c"):
+ os.path.isfile("pyspike/cython/cython_distances.c"):
use_c = True
else:
use_c = False
@@ -39,9 +38,7 @@ if use_cython: # Cython is available, compile .pyx -> .c
Extension("pyspike.cython.cython_profiles",
["pyspike/cython/cython_profiles.pyx"]),
Extension("pyspike.cython.cython_distances",
- ["pyspike/cython/cython_distances.pyx"]),
- Extension("pyspike.directionality.cython.cython_directionality",
- ["pyspike/directionality/cython/cython_directionality.pyx"])
+ ["pyspike/cython/cython_distances.pyx"])
]
cmdclass.update({'build_ext': build_ext})
elif use_c: # c files are there, compile to binaries
@@ -51,9 +48,7 @@ elif use_c: # c files are there, compile to binaries
Extension("pyspike.cython.cython_profiles",
["pyspike/cython/cython_profiles.c"]),
Extension("pyspike.cython.cython_distances",
- ["pyspike/cython/cython_distances.c"]),
- Extension("pyspike.directionality.cython.cython_directionality",
- ["pyspike/directionality/cython/cython_directionality.c"])
+ ["pyspike/cython/cython_distances.c"])
]
# neither cython nor c files available -> automatic fall-back to python backend