summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMario Mulansky <mario.mulansky@gmx.net>2015-05-08 18:06:59 +0200
committerMario Mulansky <mario.mulansky@gmx.net>2015-05-08 18:06:59 +0200
commitf688dc2e8616f914040746de845646abb158125d (patch)
tree01229c5fc4a5eee546a365595388c5159a479375 /setup.py
parent619ffd7105203938a26075c79a77d63960da9922 (diff)
introduce backend for distance function
isi- and spike distances over complete intervals are now computed without obtaining the profile first. This gives more than x2 performance improvements.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 4 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index d687240..7902066 100644
--- a/setup.py
+++ b/setup.py
@@ -22,7 +22,8 @@ else:
use_cython = True
if os.path.isfile("pyspike/cython/cython_add.c") and \
- os.path.isfile("pyspike/cython/cython_profiles.c"):
+ os.path.isfile("pyspike/cython/cython_profiles.c") and \
+ os.path.isfile("pyspike/cython/cython_distances.c"):
use_c = True
else:
use_c = False
@@ -34,12 +35,14 @@ if use_cython: # Cython is available, compile .pyx -> .c
ext_modules += [
Extension("pyspike.cython.cython_add", ["pyspike/cython/cython_add.pyx"]),
Extension("pyspike.cython.cython_profiles", ["pyspike/cython/cython_profiles.pyx"]),
+ Extension("pyspike.cython.cython_distances", ["pyspike/cython/cython_distances.pyx"]),
]
cmdclass.update({'build_ext': build_ext})
elif use_c: # c files are there, compile to binaries
ext_modules += [
Extension("pyspike.cython.cython_add", ["pyspike/cython/cython_add.c"]),
Extension("pyspike.cython.cython_profiles", ["pyspike/cython/cython_profiles.c"]),
+ Extension("pyspike.cython.cython_distances", ["pyspike/cython/cython_distances.c"]),
]
# neither cython nor c files available -> automatic fall-back to python backend