summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.travis.yml3
-rw-r--r--setup.py4
2 files changed, 5 insertions, 2 deletions
diff --git a/.travis.yml b/.travis.yml
index b687aaa..5981801 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -4,9 +4,10 @@ python:
- "2.7"
install:
- - pip install cython
+ - pip install -q cython
script:
+ - export $PYTHONPATH=$PYTHONPATH:$TRAVIS_BUILD_DIR
- python setup.py build_ext --inplace
- cd test
- nosetests
diff --git a/setup.py b/setup.py
index 31db6f8..a9f40bd 100644
--- a/setup.py
+++ b/setup.py
@@ -9,7 +9,9 @@ Distributed under the BSD License
"""
from distutils.core import setup
from Cython.Build import cythonize
+import numpy
setup(
- ext_modules=cythonize("pyspike/*.pyx")
+ ext_modules=cythonize("pyspike/*.pyx"),
+ include_dirs=[numpy.get_include()]
)