summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.travis.yml22
-rw-r--r--Readme.rst3
2 files changed, 3 insertions, 22 deletions
diff --git a/.travis.yml b/.travis.yml
deleted file mode 100644
index 2877331..0000000
--- a/.travis.yml
+++ /dev/null
@@ -1,22 +0,0 @@
-language: python
-python:
- - "2.7"
- - "3.4"
- - "3.5"
- - "3.6"
-env:
- - CYTHON_INSTALL="pip install -q cython"
- - CYTHON_INSTALL=""
-before_install:
- - sudo apt-get update
- - sudo apt-get install libblas-dev
- - sudo apt-get install liblapack-dev
- - sudo apt-get install gfortran
-install:
- - pip install scipy
- - $CYTHON_INSTALL
-
-script:
- - python setup.py build_ext --inplace
- - nosetests
- - travis_wait 30 nosetests test/numeric
diff --git a/Readme.rst b/Readme.rst
index 82f341a..bd91347 100644
--- a/Readme.rst
+++ b/Readme.rst
@@ -31,6 +31,9 @@ Additionally, depending on the used methods: ISI-distance [1], SPIKE-distance [2
Important Changelog
-----------------------------
+With version 0.7.0, support for Python 2 was dropped, PySpike now officially supports
+Python 3.7, 3.8, 3.9, 3.10.
+
With version 0.6.0, the spike directionality and spike train order function have been added.
With version 0.5.0, the interfaces have been unified and the specific functions for multivariate computations have become deprecated.