summaryrefslogtreecommitdiff
path: root/pyspike/PieceWiseConstFunc.py
diff options
context:
space:
mode:
Diffstat (limited to 'pyspike/PieceWiseConstFunc.py')
-rw-r--r--pyspike/PieceWiseConstFunc.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/pyspike/PieceWiseConstFunc.py b/pyspike/PieceWiseConstFunc.py
index e639dfc..dc57ab1 100644
--- a/pyspike/PieceWiseConstFunc.py
+++ b/pyspike/PieceWiseConstFunc.py
@@ -146,14 +146,14 @@ class PieceWiseConstFunc(object):
# cython version
try:
- from cython_add import add_piece_wise_const_cython as \
+ from cython.cython_add import add_piece_wise_const_cython as \
add_piece_wise_const_impl
except ImportError:
print("Warning: add_piece_wise_const_cython not found. Make sure \
that PySpike is installed by running\n 'python setup.py build_ext --inplace'! \
\n Falling back to slow python backend.")
# use python backend
- from python_backend import add_piece_wise_const_python as \
+ from cython.python_backend import add_piece_wise_const_python as \
add_piece_wise_const_impl
self.x, self.y = add_piece_wise_const_impl(self.x, self.y, f.x, f.y)