summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py11
1 files changed, 3 insertions, 8 deletions
diff --git a/setup.py b/setup.py
index a1ab122..8ef431a 100644
--- a/setup.py
+++ b/setup.py
@@ -23,8 +23,7 @@ else:
if os.path.isfile("pyspike/cython/cython_add.c") and \
os.path.isfile("pyspike/cython/cython_profiles.c") and \
- os.path.isfile("pyspike/cython/cython_distances.c") and \
- os.path.isfile("pyspike/directionality/cython/cython_directionality.c"):
+ os.path.isfile("pyspike/cython/cython_distances.c"):
use_c = True
else:
use_c = False
@@ -39,9 +38,7 @@ if use_cython: # Cython is available, compile .pyx -> .c
Extension("pyspike.cython.cython_profiles",
["pyspike/cython/cython_profiles.pyx"]),
Extension("pyspike.cython.cython_distances",
- ["pyspike/cython/cython_distances.pyx"]),
- Extension("pyspike.directionality.cython.cython_directionality",
- ["pyspike/directionality/cython/cython_directionality.pyx"])
+ ["pyspike/cython/cython_distances.pyx"])
]
cmdclass.update({'build_ext': build_ext})
elif use_c: # c files are there, compile to binaries
@@ -51,9 +48,7 @@ elif use_c: # c files are there, compile to binaries
Extension("pyspike.cython.cython_profiles",
["pyspike/cython/cython_profiles.c"]),
Extension("pyspike.cython.cython_distances",
- ["pyspike/cython/cython_distances.c"]),
- Extension("pyspike.directionality.cython.cython_directionality",
- ["pyspike/directionality/cython/cython_directionality.c"])
+ ["pyspike/cython/cython_distances.c"])
]
# neither cython nor c files available -> automatic fall-back to python backend