summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGard Spreemann <gspr@nonempty.org>2020-03-07 19:30:12 +0100
committerGard Spreemann <gspr@nonempty.org>2020-03-07 19:30:12 +0100
commit90e78305c8260c0f86ed330d263009004877a8db (patch)
tree130ed5334c9311e9262f0c1c480c4f51fcc0cbb8
parent1c9ce27e453f2752804fe91173143f5f03b6252d (diff)
Revert "Clean up rules."
This reverts commit ca1987e21087257843eeb7592a8bd463a85ba9b5.
-rwxr-xr-xdebian/rules10
1 files changed, 3 insertions, 7 deletions
diff --git a/debian/rules b/debian/rules
index 1107de0..f7ab00f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -11,13 +11,9 @@ LDFLAGS:=$(shell dpkg-buildflags --get LDFLAGS)
override_dh_auto_configure:
mkdir -p build
-override_dh_auto_build: ripser ripser-coeff
+override_dh_auto_build:
+ c++ $(CPPFLAGS) $(CXXFLAGS) $(LDFLAGS) -o build/ripser ripser.cpp
+ c++ $(CPPFLAGS) $(CXXFLAGS) $(LDFLAGS) -DUSE_COEFFICIENTS -o build/ripser-coeff ripser.cpp
override_dh_auto_clean:
rm -rf build
-
-ripser:
- c++ $(CPPFLAGS) $(CXXFLAGS) $(LDFLAGS) -o build/ripser ripser.cpp
-
-ripser-coeff:
- c++ $(CPPFLAGS) $(CXXFLAGS) $(LDFLAGS) -DUSE_COEFFICIENTS -o build/ripser-coeff ripser.cpp