summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHelmut Grohne <helmut@subdivi.de>2021-08-26 22:28:18 +0200
committerGard Spreemann <gspr@nonempty.org>2021-08-26 22:28:18 +0200
commitd9df7e99cb805221c12b28dee163b31217b56227 (patch)
tree8d5d7331f0c7506974295e988fc5e7a7eeb5fe9d
parentaca8c869ee590b773a71fb80f95ada1eed9bf80a (diff)
Let dpkg's buildtools.mk supply a C++ compiler
This fixes FTCBFS bug #993031. Thanks to Helmut Grohne for the patch.
-rwxr-xr-xdebian/rules6
1 files changed, 4 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index f7ab00f..decef00 100755
--- a/debian/rules
+++ b/debian/rules
@@ -5,6 +5,8 @@ CPPFLAGS:=$(shell dpkg-buildflags --get CPPFLAGS)
CXXFLAGS:=$(shell dpkg-buildflags --get CXXFLAGS)
LDFLAGS:=$(shell dpkg-buildflags --get LDFLAGS)
+-include /usr/share/dpkg/buildtools.mk
+
%:
dh $@
@@ -12,8 +14,8 @@ override_dh_auto_configure:
mkdir -p build
override_dh_auto_build:
- c++ $(CPPFLAGS) $(CXXFLAGS) $(LDFLAGS) -o build/ripser ripser.cpp
- c++ $(CPPFLAGS) $(CXXFLAGS) $(LDFLAGS) -DUSE_COEFFICIENTS -o build/ripser-coeff ripser.cpp
+ $(CXX) $(CPPFLAGS) $(CXXFLAGS) $(LDFLAGS) -o build/ripser ripser.cpp
+ $(CXX) $(CPPFLAGS) $(CXXFLAGS) $(LDFLAGS) -DUSE_COEFFICIENTS -o build/ripser-coeff ripser.cpp
override_dh_auto_clean:
rm -rf build