summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorUlrich Bauer <mail@ulrich-bauer.org>2019-05-22 20:13:04 +0200
committerUlrich Bauer <mail@ulrich-bauer.org>2019-05-22 20:13:04 +0200
commit4879faf147e96923952b248ed2552c10eb1e809c (patch)
treec9740efad48fab6def940d61027a797f2e2d11d8 /Makefile
parentd3e1bae3779cfb500422b3018e098ebea089baa8 (diff)
assemble reduction matrix per default
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile10
1 files changed, 2 insertions, 8 deletions
diff --git a/Makefile b/Makefile
index 893d776..4967c0d 100644
--- a/Makefile
+++ b/Makefile
@@ -1,7 +1,7 @@
build: ripser
-all: ripser ripser-coeff ripser-reduction ripser-coeff-reduction ripser-debug
+all: ripser ripser-coeff ripser-debug
ripser: ripser.cpp
@@ -10,15 +10,9 @@ ripser: ripser.cpp
ripser-coeff: ripser.cpp
c++ -std=c++11 ripser.cpp -o ripser-coeff -Ofast -D NDEBUG -D USE_COEFFICIENTS
-ripser-reduction: ripser.cpp
- c++ -std=c++11 ripser.cpp -o ripser-reduction -Ofast -D NDEBUG -D ASSEMBLE_REDUCTION_MATRIX
-
-ripser-coeff-reduction: ripser.cpp
- c++ -std=c++11 ripser.cpp -o ripser-coeff-reduction -Ofast -D NDEBUG -D USE_COEFFICIENTS -D ASSEMBLE_REDUCTION_MATRIX
-
ripser-debug: ripser.cpp
c++ -std=c++11 ripser.cpp -o ripser-debug -g
clean:
- rm -f ripser ripser-coeff ripser-reduction ripser-coeff-reduction ripser-debug
+ rm -f ripser ripser-coeff ripser-debug