summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorUlrich Bauer <mail@ulrich-bauer.org>2019-07-08 09:05:13 +0200
committerUlrich Bauer <mail@ulrich-bauer.org>2019-07-08 09:05:13 +0200
commitc060b310743419607927dc7206658331985388f0 (patch)
treeecccbfa8c27cc3b8386925fe1a6918f43d83243d /Makefile
parent9e1ae03dc5af992462a3c98036ffda0e00b00176 (diff)
coefficients variant
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 7d43e22..4967c0d 100644
--- a/Makefile
+++ b/Makefile
@@ -1,15 +1,18 @@
build: ripser
-all: ripser ripser-debug
+all: ripser ripser-coeff ripser-debug
ripser: ripser.cpp
c++ -std=c++11 ripser.cpp -o ripser -Ofast -D NDEBUG
+ripser-coeff: ripser.cpp
+ c++ -std=c++11 ripser.cpp -o ripser-coeff -Ofast -D NDEBUG -D USE_COEFFICIENTS
+
ripser-debug: ripser.cpp
c++ -std=c++11 ripser.cpp -o ripser-debug -g
clean:
- rm -f ripser ripser-debug
+ rm -f ripser ripser-coeff ripser-debug