summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorUlrich Bauer <mail@ulrich-bauer.org>2016-08-18 18:21:08 +0200
committerUlrich Bauer <mail@ulrich-bauer.org>2016-08-18 18:21:08 +0200
commitc130a8b6dd389456eb7d09f53f6fe676358db3d6 (patch)
tree3b485f646ce1a07a84635f3b7143839a71ed8c66 /Makefile
parent0a984f22f4c90c7a9d45b57187a6db128558d12c (diff)
added reduction matrix option to Makefile
updated readme
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 9359d43..331fdd6 100644
--- a/Makefile
+++ b/Makefile
@@ -1,7 +1,7 @@
build: ripser
-all: ripser ripser-coeff
+all: ripser ripser-coeff ripser-reduction
ripser: ripser.cpp
@@ -10,6 +10,9 @@ ripser: ripser.cpp
ripser-coeff: ripser.cpp
c++ -std=c++11 ripser.cpp -o ripser-coeff -Ofast -D NDEBUG -D USE_COEFFICIENTS
+ripser-reduction: ripser.cpp
+ c++ -std=c++11 ripser.cpp -o ripser-reduction -Ofast -D NDEBUG -D ASSEMBLE_REDUCTION_MATRIX
+
clean:
- rm ripser ripser-coeff \ No newline at end of file
+ rm -f ripser ripser-coeff ripser-reduction