summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorGard Spreemann <gspr@nonempty.org>2019-12-02 12:48:48 +0100
committerGard Spreemann <gspr@nonempty.org>2019-12-02 12:53:41 +0100
commitb1cff63e271440f84497e4f301ddcbeb0816ce60 (patch)
tree27f725677e21f94456716f8f230b1ed172807b1c /debian/rules
parent90cc4b2ff4f443dc811f57b3d0a8a47d406af07e (diff)
Add support for running on big endian architectures.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 6 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index f7ab00f..5e7de73 100755
--- a/debian/rules
+++ b/debian/rules
@@ -5,6 +5,12 @@ CPPFLAGS:=$(shell dpkg-buildflags --get CPPFLAGS)
CXXFLAGS:=$(shell dpkg-buildflags --get CXXFLAGS)
LDFLAGS:=$(shell dpkg-buildflags --get LDFLAGS)
+ENDIANNESS:=$(shell dpkg-architecture -qDEB_TARGET_ARCH_ENDIAN)
+
+ifeq (big, $(ENDIANNESS))
+ CPPFLAGS+=-DBIGENDIAN
+endif
+
%:
dh $@