summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 9359d43..331fdd6 100644
--- a/Makefile
+++ b/Makefile
@@ -1,7 +1,7 @@
build: ripser
-all: ripser ripser-coeff
+all: ripser ripser-coeff ripser-reduction
ripser: ripser.cpp
@@ -10,6 +10,9 @@ ripser: ripser.cpp
ripser-coeff: ripser.cpp
c++ -std=c++11 ripser.cpp -o ripser-coeff -Ofast -D NDEBUG -D USE_COEFFICIENTS
+ripser-reduction: ripser.cpp
+ c++ -std=c++11 ripser.cpp -o ripser-reduction -Ofast -D NDEBUG -D ASSEMBLE_REDUCTION_MATRIX
+
clean:
- rm ripser ripser-coeff \ No newline at end of file
+ rm -f ripser ripser-coeff ripser-reduction