summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index eebe266..c5cf741 100644
--- a/Makefile
+++ b/Makefile
@@ -1,7 +1,9 @@
build: ripser
+
all: ripser ripser_coeff ripser_dipha ripser_dipha_coeff
+
ripser: ripser.cpp
c++ -std=c++11 ripser.cpp -o ripser -Ofast -D NDEBUG -D FILE_FORMAT_LOWER_TRIANGULAR_CSV
@@ -15,3 +17,5 @@ ripser_dipha_coeff: ripser.cpp
c++ -std=c++11 ripser.cpp -o ripser_dipha_coeff -Ofast -D NDEBUG -D FILE_FORMAT_DIPHA -D USE_COEFFICIENTS
+clean:
+ rm ripser ripser_coeff ripser_dipha ripser_dipha_coeff