summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGard Spreemann <gspreemann@gmail.com>2017-01-24 00:09:57 +0100
committerGard Spreemann <gspreemann@gmail.com>2017-01-24 00:09:57 +0100
commit568eede438bf2677b9a509572bbedb94455bafff (patch)
tree1fa2fbf52481feb483c8b3a57c3bdd207fee8866
parente69a96b09526fb4924599915a705c4bfca30a114 (diff)
- Disable parallel build (fails mysteriously on a bison error
otherwise). - Additional cleaning rules. - DH 10.
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules12
2 files changed, 11 insertions, 3 deletions
diff --git a/debian/control b/debian/control
index 1fad44e..3371aa6 100644
--- a/debian/control
+++ b/debian/control
@@ -2,7 +2,7 @@ Source: tikzit
Section: tex
Priority: optional
Maintainer: Gard Spreemann <gspreemann@gmail.com>
-Build-Depends: debhelper (>= 9), dh-autoreconf, gobjc (>= 4.6),
+Build-Depends: debhelper (>= 10), dh-autoreconf, gobjc (>= 4.6),
libgnustep-gui-dev (>= 0.18.0), libgtk2.0-dev (>= 2.18.0), libpoppler-glib-dev,
flex, bison, autoconf (>= 2.60), automake
Standards-Version: 3.9.8
diff --git a/debian/rules b/debian/rules
index fc339cc..725d2b7 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,12 +1,20 @@
#!/usr/bin/make -f
-# export DH_VERBOSE = 1
+
+#export DH_VERBOSE = 1
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
%:
- dh $@ --sourcedirectory=tikzit
+ dh $@ --sourcedirectory=tikzit --no-parallel
override_dh_clean:
find tikzit/src -name "*.d" -exec rm -f {} \;
+ rm -f tikzit/src/common/tikzlexer.h
+ rm -f tikzit/src/common/tikzlexer.m
+ rm -f tikzit/src/common/tikzparser.h
+ rm -f tikzit/src/common/tikzparser.m
+ rm -f tikzit/src/gtk/edgedecdata.m
+ rm -f tikzit/src/gtk/icondata.m
+ rm -f tikzit/src/gtk/logodata.m
dh_clean