summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorrandomguy3 <randomguy3@7c02a99a-9b00-45e3-bf44-6f3dd7fddb64>2012-01-08 17:37:03 +0000
committerrandomguy3 <randomguy3@7c02a99a-9b00-45e3-bf44-6f3dd7fddb64>2012-01-08 17:37:03 +0000
commite9b614e436b5720c1b2c51a07c5c063197cbf1e1 (patch)
treec941e6ad7e36ea4b155945c3f2e86290d4882997 /configure.ac
parent04c737bcffd1ed1f16b33c2a4199497c881c8502 (diff)
Fix app icon and directory creation on Windows
git-svn-id: https://tikzit.svn.sourceforge.net/svnroot/tikzit/trunk@359 7c02a99a-9b00-45e3-bf44-6f3dd7fddb64
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index eba5901..c00c749 100644
--- a/configure.ac
+++ b/configure.ac
@@ -97,4 +97,24 @@ TZ_OBJC2_FEATURES
AS_IF([test "x$tz_cv_objc_properties$tz_cv_objc_fast_enumeration$tz_cv_objc_optional_keyword" != "xyesyesyes"],
[AC_MSG_ERROR([Your Objective C compiler does not support the required Objective C 2 features])])
+dnl ----------------------------------------------------------------------------
+dnl
+dnl platform-specific stuff.
+
+AC_CANONICAL_HOST
+have_msw="no"
+case $host_os in
+
+ *mingw32*)
+ have_msw="yes"
+ OBJCFLAGS="$OBJCFLAGS -mwindows"
+ AC_SUBST([WINDOWS])
+ AC_SUBST([WIN32])
+ AC_SUBST([_WIN32])
+ ;;
+
+esac
+
+AM_CONDITIONAL([WINDOWS],[test "x$have_msw" = "xyes"])
+
AC_OUTPUT