summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorGard Spreemann <gspr@nonempty.org>2019-12-28 11:21:21 +0100
committerGard Spreemann <gspr@nonempty.org>2019-12-28 15:21:15 +0100
commit62002525e87ab00cf2d39705e3f82b1bce153062 (patch)
tree1428cd6937fbf29e0a7b1373da7ae201eb917ff0 /debian/rules
parent9f42398745e2ee3c237154e3e9afffa7668d7019 (diff)
Install style file. This also requires new build-depends.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules5
1 files changed, 5 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 355ccdf..68dd482 100755
--- a/debian/rules
+++ b/debian/rules
@@ -4,9 +4,14 @@
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
export QT_SELECT = qt5
+TEXMFDEBIAN:=$(shell kpsewhich --expand-path='$$TEXMFDEBIAN')
%:
dh $@ --without cmake --buildsystem qmake
+override_dh_auto_install:
+ install -D -m 644 tex/sample/tikzit.sty debian/tikzit/$(TEXMFDEBIAN)/tex/latex/tikzit/tikzit.sty
+ dh_auto_install
+
# The tests require X.
override_dh_auto_test: