summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorrandomguy3 <randomguy3@7c02a99a-9b00-45e3-bf44-6f3dd7fddb64>2012-01-08 17:37:03 +0000
committerrandomguy3 <randomguy3@7c02a99a-9b00-45e3-bf44-6f3dd7fddb64>2012-01-08 17:37:03 +0000
commite9b614e436b5720c1b2c51a07c5c063197cbf1e1 (patch)
treec941e6ad7e36ea4b155945c3f2e86290d4882997 /src/Makefile.am
parent04c737bcffd1ed1f16b33c2a4199497c881c8502 (diff)
Fix app icon and directory creation on Windows
git-svn-id: https://tikzit.svn.sourceforge.net/svnroot/tikzit/trunk@359 7c02a99a-9b00-45e3-bf44-6f3dd7fddb64
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 117bedf..d2d558f 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -87,6 +87,13 @@ tikzit_SOURCES += \
linux/PreviewWindow.m
endif
+if WINDOWS
+tikzit.res: tikzit.rc
+ $(AM_V_GEN)windres $^ -O coff -o $@
+
+tikzit_LDADD = tikzit.res
+endif
+
common/tikzlexer.m: common/tikzlexer.lm
$(AM_V_GEN)$(LEX) -o $@ $^